IPv6環境で7 Days To Dieをプレイするとマルチプレイ時に様々な不具合が発生する件 #7DaysToDie #7DTD #ゲーム

IPv6環境で7 Days To Dieをプレイするとマルチプレイ時に様々な不具合が発生する件 #7DaysToDie #7DTD #ゲーム

先日知り合いと「7 Days To Die」をプレイしているとプロバイダーの変更(地域ケーブルTV→BIGLOBE 光)によりIPv4からIPv6環境へと移行せざるをを得なくなり、結果として「7 Days To Die」のマルチプレイヤー時に様々な不具合が発生するようになりました。

 

現象

・サーバーに入ってから5分後前後から突然ボックス系のアイテムが開けなくなる。

・木等を切っても木が倒れず、同期ズレのようなものが発生する。(別プレイヤーからは倒れているが、切った本人側はずっと木が倒れてない)

・道を歩いていくと通常ではありえない地面の下に落ちて行ってしまう(サーバー側からは落ちて行っていないが、クライアント側からは落ちて行っているように見える)

要因としては「クライアント側とサーバー側の同期ズレ」のように見えるが、指定されたポート類は全て開けられており、ポートチェッカーでも確認済み

 

 

環境

サーバー側:eo 光(IPv4)
サーバー側:QNAP QHora-301W
サーバー側:7 Days to Die Dedicated Server 19.6(β8)
プレイヤー側:BIGLOBE 光(IPv6)
プレイヤー側ルーター:NETGEAR R6350
プレイヤー側:7 Days to Die 19.6(β8)

以前までは某氏の環境が「地域ケーブルTV局のIPv4環境」だったものが「BIGLOBE 光のIPv6環境」へと移行しており、ルーターも「NETGEAR R6350」へと同時に変更されています。(これが原因の可能性も。)

 

 

 

検証

・自分が運営していないフリーサーバーで現象が発生するか確認:「当方が運営していないフリーサーバーで確認してみる」といった検証も行いましたが、こちらも同様に「5分前後でボックス系が開けなくなる」といった不具合が発生。ということはウチのサーバー固有の問題と言う訳ではなさそう。

 

・クライアント、サーバー側の再インストール:クライアントのバグである可能性もあるためSteam経由による「整合性のチェック」および「アンインストール→再インストール」は行っていますが解決しませんでした。

 

・速度は落ちるものの「IPv4環境」でプレイしてみる:BIGLOBE 光はIPv4で接続すると下り速度が驚くほど落ちてしまうものの、ほぼ従来と同様にプレイできる筈ということで設定後プレイ。結果から言うとダメでした。私のサーバーでも他人のサーバーでも同様に同期ズレと思われる「サーバーに入ってから5分前後でボックスが開けないバグ」が発生

 

要因としては「IPv4→IPv6環境への移行」「ルーター側の問題」「7 Days To Dieの不具合」かと思われますが特定には至っていません。

 

 

 

似たような問題

似たような問題はヒットしましたが「サーバーの再起動で解決する」とのことですが、当方では解決できていません。

 

 

 

バグが多いゲームだけに何が原因か全くわからない

2013年12月13日からリリースされた「7 Days To Die」ですが、2021年になっても未だに「アーリーアクセス版」で8年経っても「アルファ版」のまま

Steamのコミュニティでも「総合掲示板」の次に「Support & Bug Reports」の投稿が多いほどでバグが多いため、お察しください。

正直お手上げです…。(現時点でも解決していない)

 

 

 

追記:ルーター買い替えで解決

どうやらルーターを「NETGEAR R6350」から「Aterm WX3000HP(PA-WX3000HP)」に買い替えを行ったことで解決したとのこと。

ルーター側の問題(IPv6周りがおかしい?)だった事は間違いないようで、スッキリ。

 

雑談カテゴリの最新記事

Enable Notifications    OK No thanks